Back
Downtime

The entire ATM infrastructure is currently offline due to security measures
Started 18 Mar at 12:50pm CET, resolved 21 Mar at 07:52am CET.
Resolved
Finally the issue is resolved and the entire ATM infrastructure is online again. Thank you for your patience.
Posted 21 Mar at 07:52am CET.

Created
We will update you here ASAP.
Posted 18 Mar at 12:50pm CET.