Get in touch
Back
Maintenance

Scheduled infrastructure upgrades

Completed 9 Mar at 12:30am CET.

Updated

The scheduled maintenance has been completed.

Posted 9 Mar at 08:56am CET.
Completed

Maintenance completed

Posted 9 Mar at 12:30am CET.
Started

Scheduled infrastructure upgrade of ATM Backend Server. All ATM services will be offline for approx. 2 hours. Once maintenance is concluded we will update you here.

Posted 8 Mar at 10:30pm CET.