Get in touch
Back
Maintenance

Scheduled exchange infrastructure upgrades

Completed 21 Jan at 06:00pm CET.

Updated

The scheduled maintenance has been completed.

Posted 21 Jan at 10:38pm CET.
Completed

Maintenance completed

Posted 21 Jan at 06:00pm CET.
Started

All services will remain online during maintenance, however there will be a delay of approx. 3 hours for transactions to be completed. Once maintenance is concluded we will update you here again.

Posted 21 Jan at 03:00pm CET.